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Visual Studio Versions overview
o As of today Visual Studio 2008 is the official product version 

and installed on cluster-win.rz.rwth-aachen.de.
– Runtime available on all compute node
– Intel C/C++ and Fortran compilers integration available
– Allinea DDTlight plug available

o Visual Studio 2010 is expected to be released on April 12th 
and currently installed as RC on cluster-win-lab.rz....
– Runtime available only on RZ_HPCLAB compute nodes
– No integration of Intel C/C++ and Fortran compilers
– Comes with many enhancements for parallel programming
– Will be installed on cluster-win soon after release

o This course will cover VS2010 already (where possible)3
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VS2010 Overview (1/2)
o Introduction into using Visual Studio 2008

– Only text-mode programs are considered here, as
HPC applications typically do not use GUIs

– VS2010 offers great support for GUI development on Windows

o VS2010 provides good support for Parallel Programming:
– Support for OpenMP for Shared-Memory parallel compilation
– Debugging of parallel programs: OpenMP and MPI
– Architecture-specific compiler optimizations

o The first start of VS2010 may take a few minutes as the help 
system has to be updated. You are prompted to choose from 
several pre-defined sets of VS2010 configuration options:
I nowadays choose the C# settings (previously: C++).4
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Visual Studio: Project Management (1/5)
o Everything that you do in Visual Studio will take place within 

the context of a Solution.
– A Solution is a higher-level container for other items, for

example a Project. Any other kind of file type can also be
added to a Solution, for example documentation items.

– A Solution can not contain another Solution.
– Solutions group and apply properties across projects.

o A Project maps one to one with a compiler target.
– A Project organizes the code.

o To start your work, a new Project has to be created with
File → New → Project…6
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Win32 Console Application:
No GUI design support enabled.

Visual C++ → Win32 → 
Win32 Console
Application
Name of the Project,
A Solution of the same
name is created as well
Location where the
folder structure is
created
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Visual Studio: Project Management (3/5)

8

Choose Empty project if you already
have source files.
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Visual Studio: Project Management (4/5)
o An issue specific to our Cluster: The IntelliSense database

may not be stored on a network drive. VS2010 resolves this
automatically for you by selecting Ok.

9
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Visual Studio: Project Management (5/5)
o In many cases, the shortest way to a desired

operation can be found by right-clicking on a 
GUI element and using the context menu.

o Adding existing source code items (files) to
a project: right-click on the Project (not the
Solution !) and Add → Existing Item…

o Adding new items: right-click on the Project 
and Add → New Item…

o The folders (e.g. Source Files) do not have any
other meaning than aiding you in structuring
the files in a project. They do not map to
physical folders. Creating your own folders
may help to organize large projects.10

Solution

Project
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Source navigation in Visual Studio 2010 (1/2)

11
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o Selecting a scope + function to
navigate right into it‘s imple-
mentation.

o Right-clicking a symbol opens up
a corresponding context menu:
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Source navigation in Visual Studio 2010 (2/2)
o The Class View is available from the

menu via View → Class View as well
as the Code Definition Window.

12
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Directory layout of Visual Studio solutions
o The executable is created in the directory of the active

configuration during the build process.

o Directory structure of a solution:
<top level>                  Given user directory

<project name>      Created by VS2005 / VS2008
Debug Configuration: Debug
Release                  Configuration: Release
x64                         Platform: x64 (64bit for Amd64/Intel64)

Debug Configuration: Debug
Release               Configuration: Release

13
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Visual Studio 2010: Performance Analyzer
o VS2010 comes with new tools to analyze your (parallel) 

application‘s performance: Analyze → Profiler → New 
Performance Session, then  Analyze → Launch Performance 
Wizard

All this can be done on the
local Workstation, or in the
Cluster!

o CPU Sampling:
– Will run the application under the control of a sampling 

performance analyzer (snapshots of the program‘s call tree are 
taken at regular intervals → non-intrusive, low overhead)

14
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Performance Analyzer: CPU Sampling (1/2)

15

o Summary View highlights the program‘s Critical Path:
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o Performance information can be display on source level:
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Concurrency (1/3)
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Concurrency (2/3)
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Concurrency (3/3)

19
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Performance Analyzer: Thread Contention (1/2)
o If threads compete for resources, they can get stalled:

20
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Performance Analyzer: Thread Contention (2/2)
o Reason for this contention: OpenMP Barrier

– Support for OpenMP constructs is not yet optimal

o This analysis is crucial if you do your own synchronization!

21
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Performance Analyzer: More future features...
o Performance tuning can be a never ending story, so you need 

metrics to decide where to work / when to stop: Hardware 
Counter Information.

L2 information can be used
to measure the memory
bandwidth consumed by
the application → is your
scalability limited by the
system architecture?
The FLOPS rate is good to
estimate how efficient the
code runs!
...

22
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Agenda

o Overview and Project Management

o The Microsoft and Intel compilers
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Visual Studio Configurations (1/3)
o The set of compiler options is managed in a Configuration.
o There are two configurations pre-defined: Debug and Release.

– Debug: typical options for debugging, no optimization.
– Release: debugging still possible, some optimization options.

o The compile process can be triggered by right-clicking on the
project and choosing Build. Or from the menu: Build → Build
<projectname>.

o Build → Build Solution builds all projects in the solution.

o During and after the compile process compiler output
(informational messages, warnings, errors) is displayed in
the tool windows Output or Error List.

o By double-clicking on such a message, the cursor jumps to the
corresponding place in the code.24
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Visual Studio Configurations (2/3)
o Right-clicking on a project and choosing Properties leads to

the project configuration dialog.

25
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Visual Studio Configurations (3/3)

26

Only Win32 and x64
are supported on our
Cluster, not Itanium.

You can create
your own
configurations.
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Microsoft C/C++-specific settings
o Important General Settings:

– C/C++ → General
• Addition Include Directories: Include Path

– Linker → General
• Additional Library Directories: Library Path

– Linker → Input
• Additional Dependencies: Libraries to be used

o Important Optimization Settings:
– C/C++ → Optimization

• Optimization: General Optimization Level
• Inline Function Expansion: Inlining

– C/C++ → Code Generation
• Enable Enhanced Instruction Set: Vectorization27
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Using the Intel C/C++ compiler

1. Create a (Win32) project using the
Microsoft C/C++ compiler

2. Right-click on the Solution or on the
Project

3. Intel Parallel Studio Installed (cluster-win-beta + -lab):
Intel Parallel Composer → Use Intel C++

4. Intel Parallel Studio Not Installed (cluster-win):
Use Intel(R) C++

o Solution or Project can be converted
back to use Microsoft C/C++ as well.

o Currently only supported in Visual Studio 2008!28
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Intel C/C++-specific settings
o Most settings are the same as with Microsoft C/C++, but:
o Additional Optimization Settings:

– C/C++ → Optimization
• Generate Alternate Code Path and/or Use Intel(R) Processor

Extensions: Optimization for specific CPU
• Parallelization: Ask the compiler for automatic parallelization

– C/C++ → Language
• Recognize the Restrict Keyword: Enable C99 restrict (Tuning!)
• Enable C++0x Support: Enable first C++0x features

– Add to C/C++ → Command Line and Linker → Command Line:
• /Qtcheck: Enable source instrumentation for Thread Checker
• /Qtprofile: Enable source instrumentation for Thread Profiler

29
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Using the Intel Fortran compiler
1. Open the Project Creation dialog via File → New → Project…
2. Select Intel(R) Fortran as project type

3. Typically select Empty Project as best-suited option

o Remaining project handling does not differ from C/C++!
30
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Portable Time Measurement (1/3)
o Porting applications from Unix to Windows (or the other way

around) can be quite hard … but it was not for most user
codes (HPC) we tried on Windows.
(1) The most common problem was time measurement as

gettimeofday() is not available on Windows,
(2) followed by directory management issues where ‚/‘ instead of

‚\‘ had been used before.

o In most cases we attacked (2) using #ifdefs.
o Handling (1) depends on the programming language:

– C++: We have written a version of double realtime() for
Windows and Unix.

– FORTRAN: As the library (defined along with the language)
already provides time measurement facilities, we used these.31
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Portable Time Measurement (2/3)
#ifdef WIN32

#include <Windows.h>

#define Li2Double(x) ((double)((x).HighPart) * 4.294967296E9 + \
(double)((x).LowPart))

#else

#include <sys/time.h>

#include <time.h>

#endif

double realtime (void) {

#ifdef WIN32

LARGE_INTEGER time, freq;

double dtime, dfreq;

if (QueryPerformanceCounter(&time) == 0) { … error … }

if (QueryPerformanceFrequency(&freq) == 0) { … error … }

return Li2Double(time) / Li2Double(freq);

#else

struct timeval tv;

gettimeofday(&tv, (struct timezone*)0);

return ((double)tv.tv_sec + (double)tv.tv_usec / 1000000.0 ); 

}

32
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Portable Time Measurement (3/3)
o Taking time the MPI way:
#include <mpi.h>

...

double t1, t2, elapsed_seconds;

t1 = MPI_Wtime();

...

t2 = MPI_Wtime();

elapsed_seconds = t2 - t1;

o Taking time the OpenMP way:
#include <omp.h>

...

double t1, t2 elapsed_seconds;

t1 = omp_get_wtime();

...

t2 = omp_get_wtime();

elapsed_seconds = t2 - t1;33
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Enabling OpenMP (1/3)
o OpenMP support has to be enabled in a configuration:

35

OpenMP 2.0 / 2.5:

• VS2005 C/C++

• VS2008 C/C++

• VS2010 C/C++

OpenMP 3.0:

• Intel C/C++

• Intel FORTRAN
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Enabling OpenMP (2/3)

o Known problem with Visual Studio and OpenMP:

o The message appears if an OpenMP program has been 
compiled with OpenMP support enabled, but omp.h had
not been included.

o Solution: include omp.h in at least one file per project.36
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Enabling OpenMP (3/3)
o Setting the number of threads for debugging of OpenMP 

programs: set environment variable OMP_NUM_THREADS.

37
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Enabling MPI (1/2)

o As MPI is implemented by a library, an application includes
a file containing the type and function declarations named 
mpi.h and has to be linked with that library.

o Modify the project properties (1/2):
– Include Path: C/C++ → General → Additional Include Directories

• MS-MPI 2008 on cluster-win / cluster-win-lab :
C:\Program Files\Microsoft HPC Pack 2008 SDK\Include

• I-MPI on cluster-win:
C:\Program Files 
(x86)\Intel\ICT\3.1\mpi\3.1\[ia32|em64t]\include

38
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Enabling MPI (2/2)

o Modify the project properties (2/2):
– Library Path: Linker → General →  Additional Library Directories

• MS-MPI 2008 on cluster-win / cluster-win-lab :
C:\Program Files\Microsoft HPC Pack 2008 SDK\Lib\[i386|amd64]

• I-MPI on cluster-win:
C:\Program Files (x86)\Intel\ICT\3.1\mpi\3.1\[ia32|em64t]\lib

o No significant performance difference, so our advise:
– Use MS-MPI with Visual Studio MPI Debugger
– Use I-MPI with Intel Thread Analyzer & Collector
– Sometimes a program does not like a specific MPI, so it is

always a good thing to have a second one available…39
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Debugging Basics (1/2)
o A breakpoint can be set by clicking in the grey area left of the

line number. Clicking again removes the breakpoint.

o Right-clicking a breakpoint opens the context menu with the
following functions
– Disable a breakpoint (temporarily)
– Set breakpoint trigger conditions
– Trigger filter for selected threads or processes
– Define actions to be executed when the breakpoint is triggered

o Just hold the mouse over a variable for a short moment to
get the actual value displayed (hover). This is also possible for
expression (with some limitations).
– Clicking the pin laminates the variable display

41
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Debugging Basics (2/2)
o During a debugging session, the actual program location is

marked by a yellow arrow. You can drag this arrow up/down.

42
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Debugging OpenMP Programs (1/4)
o Debugging of OpenMP applications in Visual Studio works 

with all compilers: the Microsoft C/C++ compiler, the Intel 
C/C++ compiler and the Intel Fortran compiler.

o Note: If you use one of the Intel compilers or VS21010 and
start a program with n threads, you will see n+1 threads
(one management thread).

o We advise you to compile without any optimization for
debugging, that means use the pre-configured Debug
configuration and just enable OpenMP.

o Control debugging:
» Start / Continue, Break, Stop, Restart

» Show next statement, Step Into, Step Over, Step Out
43
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Debugging OpenMP Programs (2/4)
o All threads stop at a breakpoint (first thread encounters it).

– You can open the Threads register from the menu via Debug → 
Windows → Threads. Double-clicking a thread will select it.

– If you want a thread to stand still you Freeze it (context menu).
– If you want it to continue Thaw it.44
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Debugging OpenMP Programs (3/4)
o For all threads, you can view the local and shared variables.

– The Locals register contains all variables of the current scope.
– The Autos register contains a set of interesting variables 

guessed by the compiler – remarkably good.
o Some limitations when using the Intel Fortran compiler:

– The Autos register is empty, Locals is working fine.
– One can not (at least sometimes) identify the management

thread by the name – it is the one you get an error message
of no source code being available if you select it ;-)

– Sometimes expressions have to be updated because of
(possible) compiler optimization.

45
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Debugging OpenMP Programs (4/4)
o The Parallel Stacks window is a new feature of VS2010 and in 

the menu under Debug → Windows → Parallel Stacks:

46
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Allinea DDTlite Overview

o DDTlite is a plugin for Visual Studio 2008 SP1 (and newer)
– Mainly marketed for improved MPI debugging experience
– But also improves OpenMP debugging experience

o Adds the following features:
– Control processes and threads individually, grouped or together
– Examine variable values per thread / process
– Parallel Stack View per thread / process
– Location View per thread / process
– Thread / process group management

o For a trial version go to www.allinea.com
47
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Debugging OpenMP Programs w/ DDTlite 
o Select and switch between threads individually:

o Compare variables per thread:

48
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Debugging MPI programs (1/6)
o MS-MPI works best, but you should be able to use I-MPI as

well. At least the following instructions work for both.
o Visual Studio supports debugging of MPI programs using the 

Cluster Debugger. As far as I know – or was able to verify –
the cluster debugger only works with the Microsoft C/C++ 
compiler and not with projects using the Intel C/C++ compiler
or the Intel FORTRAN compiler.

o In the project properties under Debugging, choose the MPI 
Cluster Debugger as Debugger to launch. For VS2008 only:
– MPIRun: „C:\Program Files\Microsoft HPC Pack 2008 SDK\Bin “
– MPIRun Arguments: for example –n 2
– MPIShim Location:

It is not possible to specify a path containing empty spaces here, so you have 
to copy MPIShim from c:\program files[ (x86)]\microsoft visual studio 9.0 
\common7\ide\RemoteDebugger\x86[or x64]\MPIShim to a suitable location.

50
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Debugging MPI programs (2/6)
o In order to stop all processes at a breakpoint, please check 

for the following option: In Tools → Options → Debugging → 
General the checkbox Break all processes when one process
breaks has to be activated.

o Select the current process using the Processes register.

o Problem: if one process does a step, all other processes make
a step as well.
– Solution 1: Be clever setting breakpoints …
– Solution 2: Detach the second (and third and fourth and …)  

process from the VS debugger (remember the right-click and 
context menu), open up another VS instance (maybe more)
and attach to the process.

– Solution 3: Use DDTlight
51
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Debugging MPI programs (3/6)
o In VS2010 you can just go with the defaults:

52

Debug on the local
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four MPI processes
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Debugging MPI programs (4/6)

53

Slave

Master
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Debugging MPI programs (5/6)
o You can also F5 to the Cluster, if there are free slots:
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Debugging MPI programs (6/6)
o A VS2010 debug job running on our Cluster:

55
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DDTlite: Overview

o Allinea DDT Lite is an add-in for Visual Studio 2008 SP1
– Currently an additional patch to VS2008 is required

o Significantly improves the MPI debugging experience
– Debug / Control MPI processes individually
– Debug / Control groups of MPI processes individually
– Display variable values per process side-by-side
– Display MPI process stacks side-by-side
– …

o For a trial version go to www.allinea.com56
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DDTlite: Usage
o Configure project to use the MPI Cluster Debugger

o Tools -> Add-in Manager
– Select Allinea DDTlite
– Enable Startup

o Start Debugging (e.g. via F5)
o Debug -> Windows -> Show DDTLite Windows

– Selected Processes and Threads
– Groups – Parallel View
– Variable – Parallel View
– Location – Parallel View
– Parallel Stack View57
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The End

Thank you for

your attention!

58


	Visual Studio for HPC Application Development
	Agenda
	Visual Studio Versions overview
	VS2010 Overview (1/2)
	Foliennummer 5
	Visual Studio: Project Management (1/5)
	Foliennummer 7
	Visual Studio: Project Management (3/5)
	Visual Studio: Project Management (4/5)
	Visual Studio: Project Management (5/5)
	Source navigation in Visual Studio 2010 (1/2)
	Source navigation in Visual Studio 2010 (2/2)
	Directory layout of Visual Studio solutions
	Visual Studio 2010: Performance Analyzer
	Performance Analyzer: CPU Sampling (1/2)
	Performance Analyzer: CPU Sampling (2/2)
	Concurrency (1/3)
	Concurrency (2/3)
	Concurrency (3/3)
	Performance Analyzer: Thread Contention (1/2)
	Performance Analyzer: Thread Contention (2/2)
	Performance Analyzer: More future features...
	Agenda
	Visual Studio Configurations (1/3)
	Visual Studio Configurations (2/3)
	Visual Studio Configurations (3/3)
	Microsoft C/C++-specific settings
	Using the Intel C/C++ compiler
	Intel C/C++-specific settings
	Using the Intel Fortran compiler
	Portable Time Measurement (1/3)
	Portable Time Measurement (2/3)
	Portable Time Measurement (3/3)
	Agenda
	Enabling OpenMP (1/3)
	Enabling OpenMP (2/3)
	Enabling OpenMP (3/3)
	Enabling MPI (1/2)
	Enabling MPI (2/2)
	Agenda
	Debugging Basics (1/2)
	Debugging Basics (2/2)
	Debugging OpenMP Programs (1/4)
	Debugging OpenMP Programs (2/4)
	Debugging OpenMP Programs (3/4)
	Debugging OpenMP Programs (4/4)
	Allinea DDTlite Overview
	Debugging OpenMP Programs w/ DDTlite 
	Agenda
	Debugging MPI programs (1/6)
	Debugging MPI programs (2/6)
	Debugging MPI programs (3/6)
	Debugging MPI programs (4/6)
	Debugging MPI programs (5/6)
	Debugging MPI programs (6/6)
	DDTlite: Overview
	DDTlite: Usage
	The End

